Degraded Performance: Users may be unable to assign or unassign loads from the Orders screen and Dispatch Calendar view.

Incident Report for Toro TMS

Resolved

This incident has been resolved.
Posted Aug 04, 2025 - 21:55 EDT

Monitoring

A fix has been implemented and we are currently monitoring results.
Posted Aug 04, 2025 - 20:48 EDT

Investigating

We are currently investigating this issue and will provide an update within the next 15 minutes.
Posted Aug 04, 2025 - 20:42 EDT
This incident affected: General Site Performance.