The Amazon Web Services outage that impacted our messaging provider has been resolved. Dispatch text deliveries and overall platform performance have returned to normal and are fully operational.
Posted Oct 20, 2025 - 22:25 EDT
Monitoring
Amazon Web Services has implemented a fix to mitigate the outage, and we are seeing signs of overall recovery. We continue to monitor the situation with our messaging service provider to confirm full restoration.
Improvement is being observed in both dispatch text deliveries and overall platform performance.
Posted Oct 20, 2025 - 15:32 EDT
Identified
An ongoing AWS (Amazon Web Services) outage is affecting our messaging provider. As a result, dispatch text messages may be delayed or fail to send.
Additionally, users may experience intermittent slowness or degraded performance when navigating the Toro platform.
Our team is monitoring the situation closely and will provide updates as more information becomes available.
Posted Oct 20, 2025 - 14:42 EDT
Investigating
An ongoing AWS (Amazon Web Services) outage is affecting our messaging provider. As a result, dispatch text messages may be delayed or fail to send.
Additionally, users may experience intermittent slowness or degraded performance when navigating the Toro platform.
Our team is monitoring the situation closely and will provide updates as more information becomes available.
Posted Oct 20, 2025 - 14:41 EDT
This incident affected: General Site Performance and Driver Communications (Toro Driver Communications, Upstream Messaging Provider).