QuickBooks Desktop: intermittent sync and processing errors on large datasets

Incident Report for Toro TMS

Resolved

This incident has been resolved. Please contact support@torotms.com if you experience any issues.
Posted Sep 03, 2025 - 17:27 EDT

Monitoring

A fix has been implemented and affected QuickBooks Desktop users should be able to observe syncs returning to normal. Our team will continue to monitor to ensure continued stability.

Please contact support@torotms.com if you experience any issues.
Posted Aug 27, 2025 - 15:24 EDT

Investigating

We are aware of an issue with our QuickBooks Desktop / Web Connector integration that may cause errors when processing large datasets. Impacted users may see messages such as “ReceiveResponseXML failed” or “FetchErrors” during data refreshes. Our team is working with our integration partner to investigate and will share updates as soon as more information is available.
Posted Aug 25, 2025 - 15:45 EDT
This incident affected: QuickBooks Integration (QuickBooks Desktop Connector).