Upstream service outage impacting QuickBooks Syncs

Incident Report for Toro TMS

Resolved

Cloudflare has resolved the upstream issue, and downstream services have remained stable since the fix was implemented.

QuickBooks syncs, including both Desktop and Online, are operating normally. This incident is considered resolved.

Please reach out to support@torotms.com if you continue to experience any issues with QuickBook syncs.
Posted Nov 18, 2025 - 16:02 EST

Monitoring

Cloudflare has announced that a fix has been implemented on their end and they are now monitoring for stability.

As a result, downstream services, including QuickBooks Desktop and Online syncs, should begin recovering for Toro users. We are actively monitoring system performance to confirm stability and ensure successful reconnections across all affected services.

We’ll continue to track this closely and will provide a final update once full recovery is confirmed.
Posted Nov 18, 2025 - 10:00 EST

Identified

We are currently experiencing an outage impacting QuickBooks syncs for some users. This is due to an upstream issue with one of our service providers, Cloudflare, which is affecting connectivity to our accounting integrations and related downstream services.

Cloudflare has posted an active incident on their status page. We are actively monitoring the situation from our side and are also tracking updates directly through their status channels.

We’ll provide updates here as more information becomes available.
Posted Nov 18, 2025 - 09:27 EST
This incident affected: QuickBooks Integration (QuickBooks Online Connector, QuickBooks Desktop Connector).