Messaging & SMS Delivery Degradation

Incident Report for Toro TMS

Resolved

The messaging and dispatch issue has been fully resolved. Message delivery is now functioning as expected, and we have confirmed stable performance across affected services.

Thank you for your patience while we worked to restore service.
Posted Apr 17, 2025 - 18:57 EDT

Monitoring

A fix has been deployed, and we are observing signs of recovery. Most users should now be able to send and receive dispatch messages as expected. We will continue to monitor closely to ensure full stability and restoration.

If you continue to experience issues with messaging, please contact us at support@torotms.com.
Posted Apr 17, 2025 - 18:26 EDT

Identified

Our messaging service provider has identified the root cause of the issue impacting message delivery. A fix is currently being deployed, and we’ll provide another update shortly.

At this time, we’ve applied a temporary update that allows outbound messages and dispatch texts to successfully reach drivers. However, inbound messages from drivers to the Toro number may still be impacted and could fail to deliver.
Posted Apr 17, 2025 - 17:45 EDT

Update

We are currently experiencing degraded performance affecting message and SMS delivery. Impacted users may encounter delays, intermittent failures, or fluctuations in message delivery success. Our team is actively investigating and working to restore service as quickly as possible.

Please follow this link for immediate workaround options:
https://torotms.zendesk.com/hc/en-us/articles/36099103147547-Dispatch-Messaging-Outage
Posted Apr 17, 2025 - 16:50 EDT

Investigating

We are currently experiencing degraded performance affecting message and SMS delivery. Impacted users may encounter delays, intermittent failures, or fluctuations in message delivery success. Our team is actively investigating and working to restore service as quickly as possible.
Posted Apr 17, 2025 - 16:19 EDT
This incident affected: Driver Communications (Toro Driver Communications).