Messaging & SMS Delivery Degradation

Incident Report for Toro TMS

Resolved

The issue affecting MMS and SMS message deliveries has been resolved. All services are now operating normally.

We’ll continue to monitor performance, but no further impact is expected. Thank you for your patience while we worked to address the issue

If you have any questions or are still experiencing problems, please reach out to support@torotms.com.
Posted Mar 21, 2025 - 11:26 EDT

Monitoring

We are now observing successful MMS and SMS message deliveries. We will continue to monitor this issue, if you have any questions please contact support@torotms.com
Posted Mar 19, 2025 - 19:39 EDT

Identified

We are currently experiencing degraded performance affecting message and SMS delivery due to ongoing maintenance by our messaging service provider. Some users may encounter delays, intermittent failures, or fluctuations in message delivery success.

Our team is actively monitoring the situation and working with our provider to resolve the issue. We will provide updates as soon as more information becomes available.
Posted Mar 19, 2025 - 11:50 EDT
This incident affected: Driver Communications (Toro Driver Communications).