Dispatch Messaging Delays - Impacting T-Mobile Network

Incident Report for Toro TMS

Resolved

The delivery delays when sending messages to the T-Mobile network in the United States have been fully resolved. Messages are now being delivered as expected.
Please reach out to support@torotms.com if you require further assistance.
Posted Feb 10, 2025 - 09:07 EST

Identified

We are currently experiencing delays in sending messages to the T-Mobile Network. Our messaging platform is currently working with the carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Feb 07, 2025 - 15:55 EST
This incident affected: Driver Communications (Toro Driver Communications).