Degraded Performance - Toro

Incident Report for Toro TMS

Resolved

This incident has been resolved.
Posted Oct 15, 2024 - 19:19 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 15, 2024 - 16:18 EDT

Investigating

We are currently investigating an issue with degraded performance within Toro. We are actively working on a fix, and will provide an update as soon as possible. You may be currently experiencing issues with the following:

- Dispatch
- Creating Invoices
- Creating Orders
- Updating Charges, Appointment Times, and Reference Numbers
Posted Oct 15, 2024 - 16:03 EDT
This incident affected: General Site Performance.